You’re reading all articles tagged 'bug'

Dark alpha PNGs in Safari 2

27 Sep 2005

Here’s a weird one, and it only affects Safari 2 (Tiger), not even Safari 1.3 or earlier, or Omniweb (using the earlier rendering engine).

If you look at my ‘contact section’, or my live search function, I use an alpha png in the background to overlay a transparent white tint over the header image. In every other browser (except IE of course, which just gets a white background) this works just as I expect it to, but not in Safari 2. The effect is transparent grey – not white. Richard Rutter was kind enough to check in Safari 1.3 for me, and the png shows up fine.

Apart from Paul Haine, I couldn’t find anyone else that was experiencing this problem.

After a lot of experimentation however, it turned out that Safari just needs the repeating image to be at least 2px square, not 1px.

Here’s a comparison:

Screenshot of before, using a 1px square png, and after, using 2px

I hope this is useful to someone else, who may have come across this problem.


Instagram Hickstagram

  • 14 Jul 2018

    Stopping for a breather - hot day for hills

  • 13 Jul 2018

  • 09 Jul 2018

    Recent garden addition: Stargazer Lillies

  • 07 Jul 2018

    Well… we missed quite a few key acts, but have made it here before Interpol starts at least!

  • 07 Jul 2018

    On our way to BST in Hyde Park. Or… not 😞

  • 06 Jul 2018

    My favourites from this years On Form Sculpture exhibition. The whale was my absolute favourite, but was already sold (which is fine as I don’t have a spare £11,000)

  • 01 Jul 2018

  • 01 Jul 2018

    Not quite in height order. Sort it out

  • 01 Jul 2018

    Filth.

  • 30 Jun 2018

    Agapanthus about to burst forth

Contact us

Call Jon on +44 (0)7917 391536, email or tweet @hicksdesign.

Alternatively, pop in for tea and cake at the studio…

Hicks
Wenrisc House
Meadow Court
Witney, OX28 6ER
United Kingdom